DocuSign - Latency and Intermittent Errors

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 10:45 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2026 - 08:37 EDT

Update

Vendor has a solution in place and we are monitoring.
Posted Jul 30, 2026 - 16:27 EDT

Investigating

Vendor has indicated that they are investigating the reports of Latency and Intermittent Errors.
They also have indicated that some Customers are experiencing errors when signing up for new accounts
Posted Jul 30, 2026 - 16:24 EDT
This incident affected: Other Applications (Other Application).