Turnitin Feedback Studio Issue
Incident Report for Millersville University
Resolved
The Turnitin company suffered, but have resolved, an unexpected outage with their primary Internet provider. During the outage you may have experienced difficulty launching or using Turnitin Feedback Studio. The outage began at 10:08am Eastern and was resolved by 11:54am Eastern.
Posted Apr 21, 2020 - 12:56 EDT
Monitoring
The Turnitin company identified a problem at one of their network providers as the source of the Feedback Studio issue. Turnitin are rerouting connections to Feedback Studio to avoid the network disruption.
Posted Apr 21, 2020 - 11:52 EDT
Identified
Turnitin Feedback Studio is currently experiencing an unexpected service disruption. The Turnitin company are working to resolve the problem. In the meantime you may experience difficulty launching Feedback Studio or using Feedback Studio once it opens.
Posted Apr 21, 2020 - 11:20 EDT
This incident affected: D2L Brightspace & Related Services (Turnitin Feedback Studio).