Multiple Services Affected
Incident Report for Millersville University
Resolved
All applications are working as expected and issues have been monitored and resolved.
Posted Jun 03, 2020 - 16:01 EDT
Investigating
Due to a server certificate issue, multiple certificate-based IT services are experiencing errors this morning. We are working diligently to restore full service as quickly as possible.
Posted Jun 01, 2020 - 09:12 EDT
This incident affected: Phones & Voicemail and Other Applications (Cascade CMS).