Wireless and Wired Network Connectivity

Incident Report for Millersville University

Resolved

A fix has been implemented, and we will continue to monitor connectivity.
Posted Jul 02, 2026 - 20:13 EDT

Investigating

We are currently aware that some individuals are unable to connect to the internet via Wi-Fi or wired connection. We are investigating the issue and will provide updates as they are available
Posted Jul 02, 2026 - 15:16 EDT
This incident affected: Internet and Wireless.