MU Video Down
Incident Report for Millersville University
Resolved
Kaltura, the company that hosts MU Video, have implemented a fix, and MU Video is operational again.
Posted Mar 26, 2020 - 16:43 EDT
Investigating
A problem with the MU Video web site is causing it to respond slowly and display errors. Kaltura, the company that hosts MU Video, are investigating.
Posted Mar 26, 2020 - 16:04 EDT
This incident affected: MU Video (MU Video).