Cascade CMS Down

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 13:31 EDT

Investigating

The vendor is aware of the issue and is working to resolve it. We will update the status when we receive confirmation that the issue is resolved.
Posted Jul 11, 2025 - 12:57 EDT
This incident affected: Other Applications (Cascade CMS).