Coursedog Products Curriculum, Catalog, Events, Academic Scheduling Outage

Incident Report for Millersville University

Resolved

Vendor has corrected the problem and all systems are once again available for use.
Posted Jul 21, 2026 - 20:25 EDT

Investigating

Coursedog products are experiencing issues where the system is unavailable or will log a user out. Login issues are sporadic and we are waiting for the vendor to resolve the issues.
Posted Jul 21, 2026 - 16:57 EDT
This incident affected: Other Applications (Coursedog Events, CAP (Coursedog Curriculum)).