Get Involved Authentication Currently Unavailable

Incident Report for Millersville University

Resolved

Working with Get Involved vendor we have resolved the issues and made changes to allow new student accounts to be created.
Posted Aug 21, 2025 - 11:48 EDT

Identified

IT is working with Get Involved support to restore service. This will continue until Thursday morning until around 9am.
Posted Aug 20, 2025 - 16:08 EDT
This incident affected: Other Applications (Other Application).