MU Mobile ID Issuance Unavailable

Incident Report for Millersville University

Resolved

MU Mobile ID's are now able to be issued.
Posted Aug 22, 2026 - 21:57 EDT

Investigating

We are currently experiencing an issue with a vendor system that supports MU Mobile ID provisioning. As a result, new MU Mobile IDs cannot be issued at the present time.

This does not affect anyone who already has a MU Mobile ID on their device. Existing MU Mobile IDs continue to function normally across campus.
Posted Aug 22, 2026 - 16:04 EDT
This incident affected: Other Applications (Mobile Credentials/Card ID).