Argos Reporting is Unavailable

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 09:55 EDT

Investigating

Our PASSHE Central Admin office has been contacted and will be reaching out to the vendor.
Posted Jul 16, 2026 - 07:47 EDT
This incident affected: Other Applications (MU Reporting/Argos).