Turnitin License Messages

Incident Report for Millersville University

Resolved

Turnitin corrected PASSHE's license expiration date in their systems.
Posted Jul 15, 2025 - 16:25 EDT

Investigating

Turnitin tools—including Feedback Studio and Draft Coach—are erroneously reporting their licensing has expired. PASSHE hold a current contract with Turnitin and are working with the company to fix this problem.
Posted Jul 15, 2025 - 09:16 EDT
This incident affected: D2L Brightspace & Related Services (Turnitin Feedback Studio) and Other Applications (Other Application).