www Currently Unavailable

Incident Report for Millersville University

Resolved

We have been able to resolve the problem with the www website and will continue to monitor.
Posted Jan 30, 2020 - 17:07 EST

Identified

We are currently experiencing problems with our website and are working to bring it back up.
Posted Jan 30, 2020 - 16:57 EST
This incident affected: www Main Website - External.