IT Is Currently Remote
Incident Report for Millersville University
Resolved
Due to a building mechanical malfunction, the IT Help Desk, typically located in Boyer 230, has been moved to the right side of the building. The IT Help Desk call center remains open, and we are here to assist you! You can reach us at 717-871-7777 or by submitting a ticket via the self-service portal in myVILLE.
Posted May 02, 2024 - 09:28 EDT
Update
Due to a building mechanical malfunction, the IT Help Desk, located in Boyer 230, will be closed for walk-in appointments on Wednesday, May 1st. The IT Help Desk call center remains open, and we are here to assist you! You can reach us at 717-871-7777 or by submitting a ticket via the self-service portal in myVILLE.
Posted May 01, 2024 - 07:23 EDT
Update
Due to a building mechanical malfunction, the IT Help Desk, located in Boyer 230, will be closed for walk-in appointments on Wednesday, May 1st. The IT Help Desk call center remains open, and we are here to assist you! You can reach us at 717-871-7777 or by submitting a ticket via the self-service portal in myVILLE.
Posted Apr 30, 2024 - 17:03 EDT
Update
Due to a building mechanical malfunction, the IT Help Desk, located in Boyer 230, will be closed for walk-in appointments on Wednesday, May 1st. The IT Help Desk call center remains open, and we are here to assist you! You can reach us at 717-871-7777 or by submitting a ticket via the self-service portal in myVILLE.
Posted Apr 30, 2024 - 16:37 EDT
Monitoring
IT in person services are currently suspended due to an issue in the building. Please call in for remote assistance at 717-871-7777 or submit a ticket through myVILLE portal.
Posted Apr 30, 2024 - 14:16 EDT