Internet Bandwidth Degraded.
Incident Report for Millersville University
Postmortem

Resnet Core Router has internal fault, replaced Core.

Posted May 01, 2020 - 17:36 EDT

Resolved
Full bandwidth has been restored to the Millersville Residential Network.
Posted May 01, 2020 - 17:35 EDT
Investigating
We are currently experiencing slow Internet service on campus, particularly in the resident halls.
We are working our provider to identify the issue.
Stay tuned.
Posted Apr 29, 2020 - 18:38 EDT
This incident affected: Internet and Wireless.