Turnitin Outage

Incident Report for Millersville University

Resolved

PASSHE worked with Turnitin to resolve this issue.
Posted Sep 10, 2025 - 13:21 EDT

Investigating

Turnitin tools—including Feedback Studio in D2L and Draft Coach in Word—are erroneously reporting their licensing has expired. PASSHE are working with Turnitin to restore service.
Posted Sep 10, 2025 - 09:23 EDT
This incident affected: D2L Brightspace & Related Services (Turnitin Feedback Studio) and Other Applications (Other Application).