Ess, eTime, and Sourcepoint Error

Incident Report for Millersville University

Resolved

PASSHE has restored access to ESS, eTime, and Sourcepoint. We will continue to monitor connectivity.
Posted Mar 24, 2026 - 13:52 EDT

Update

Currently SAP and all ESS applications are inaccessible. PASSHE is continuing to work with SAP on a resolution.
Posted Mar 24, 2026 - 09:44 EDT

Investigating

We are investigating reports of issues with eTime and ESS. Updates will be posted as they become available.
Posted Mar 23, 2026 - 08:34 EDT

Identified

PASSHE has reported login issues with SourcePoint. If you receive a warning, click "Advanced" and proceed. (this is not a normal recommendation, only for this instance)
Posted Mar 18, 2026 - 08:48 EDT
This incident affected: Other Applications (ESS/SAP/BI, Other Application).