Argos Reporting Tool is Unresponsive

Incident Report for Millersville University

Monitoring

The fix has been implemented and the vendor is now monitoring.
Posted Apr 30, 2026 - 07:25 EDT

Investigating

We have notified the Argos vendor of the issue.
Posted Apr 29, 2026 - 14:56 EDT
This incident affects: Other Applications (MU Reporting/Argos).