Microsoft 365 Applications and Authentication Service Degraded

Incident Report for Millersville University

Resolved

Microsoft has resolved the issue, and all applications should be accessible and functioning as expected.
Posted Oct 30, 2025 - 09:32 EDT

Investigating

Microsoft has reported that they are having issues with multiple of their products restricting access to some users to various products. Authentication and access to applications may be limited during this time.
Posted Oct 29, 2025 - 15:34 EDT
This incident affected: Authentication and Other Applications (Microsoft Teams).