ID Card/Mobile ID Issue

Incident Report for Millersville University

Resolved

A fix has been implemented, and all student ID Cards and Mobile IDs should be functioning normally.
Posted Dec 08, 2025 - 14:34 EST

Identified

We are aware that a limited population of students are having issues with their ID Card / MU Mobile ID. The problem has been identified, and a fix is being implemented. Updates will be posted as they become available.
Posted Dec 02, 2025 - 10:57 EST
This incident affected: Other Applications (Cbord Card ID & Web).