Connect Banner Admin (On Prem) Intermittent
Incident Report for Millersville University
Resolved
This issue has been resolved. If you continue to have issues, please submit a ticket through myVille Portal
Posted Jan 14, 2025 - 13:12 EST
Investigating
Connections to Banner Admin (On Prem) may be intermittent as we work on restoring full connections.
Posted Jan 13, 2025 - 10:07 EST
This incident affected: Banner (Banner Admin).