Facilities Work Order System Unavailable

Incident Report for Millersville University

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 13:29 EDT

Investigating

Brightly is reporting login issues with Asset Essentials. Brightly is working on a resolution and we'll post updates as soon as they are available.
Posted Mar 17, 2026 - 11:16 EDT
This incident affects: Other Applications (Other Application).