Brightly Maintenace Workorder System Issue
Incident Report for Millersville University
Resolved
Brightly has confirmed that it is back up. If you continue to experience issues, please contact Facilities at (717) 871-7875
Posted Jul 22, 2024 - 08:14 EDT
Investigating
Brightly, the maintenance workorder system, is currently unavailable.

The vendor is having technical issues
Posted Jul 19, 2024 - 10:46 EDT
This incident affected: Other Applications (Other Application).