VillePrint Email to Print Issue

Incident Report for Millersville University

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 15:42 EST

Investigating

We are investigating reports of issues with VillePrint. Updates will be posted as they become available.
Labs that can direct print can be found here:
Luek 109 LUEK
McComsey 235
McNairy Library Knowledge Commons
Stayer 2nd Floor
Wickersham 108
Posted Mar 03, 2026 - 14:34 EST
This incident affects: Other Applications (Student Printing).