Outlook Online Connection Issues
Incident Report for Millersville University
Resolved
Outlook online connection issues are resolved. If you continue to have issues, please reach out to the Help Desk through the myVILLE portal.
Posted Nov 26, 2024 - 08:30 EST
Investigating
Microsoft reports that users may experience issues connecting to Outlook Web app. We will post updates as we get them.
Posted Nov 25, 2024 - 13:21 EST
This incident affected: Other Applications (Other Application).