Off Campus vLab and MyDesktop Outage
Incident Report for Millersville University
Resolved
We have resolved the certificate issue with vLab and MyDesktop.
Posted Jul 16, 2024 - 15:23 EDT
Update
We're working on a fix for off-campus vLab and My Desktop access. We'll keep you updated as we make progress. Stay tuned for more information!
Posted Jul 16, 2024 - 14:09 EDT
Investigating
We are investigating reports of issues with off campus use of vLab and My Desktop. Updates will be posted as they become available.
Posted Jul 16, 2024 - 14:06 EDT
This incident affected: Virtual Desktops (Staff Standard, VLab).