MU Video Unavailable
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Aug 03, 2020 - 11:30 EDT
Monitoring
The vendor has implemented a fix, and the MU Video site and tools are operational again. Millersville IT are monitoring the system.
Posted Aug 03, 2020 - 08:32 EDT
Investigating
The MU Video site and tools, including those within D2L, are unavailable. The vendor is working on the problem. Updates will be posted as they become available.
Posted Aug 03, 2020 - 08:23 EDT
This incident affected: MU Video (MU Video).