myVILLE Issue

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted May 30, 2025 - 10:38 EDT

Update

We are continuing to monitor for any further issues.
Posted May 23, 2025 - 15:33 EDT

Monitoring

A fix has been implemented and we are monitoring for any issues.
Posted May 23, 2025 - 15:33 EDT

Identified

We have identified the issue and are working on a resolution. During this time, you can expect multiple refreshes of the site when you visit it, and some content will remain unavailable.
Posted May 21, 2025 - 09:13 EDT

Investigating

We are investigating reports of issues with loading myVille Portal. Updates will be posted as they become available.
Posted May 21, 2025 - 08:00 EDT
This incident affected: myVILLE.