WWW Access Issue Issue

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 08:21 EDT

Investigating

We are investigating reports of issues with accessing the www.millersville.edu website. Updates will be posted as they become available.
Posted Sep 04, 2026 - 08:14 EDT
This incident affected: www Main Website - External.