Outage - OnBase Document Management System (digital forms impacted)

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 12:46 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 12:09 EDT

Investigating

The vendor is working on the issue. This is a cloud/off prem application so we are depending on our vendor for the resolving the issue.
Posted Jul 14, 2025 - 11:54 EDT
This incident affected: Other Applications (Document Management System (OnBase)).