Outlook Issue

Incident Report for Millersville University

Monitoring

Microsoft has implemented a fix - we are monitoring results at this time.
Posted Jan 23, 2026 - 08:29 EST

Investigating

Microsoft has reported that they are investigating multiple reports of issues with Microsoft Outlook. This is also preventing scan to email functions from our Ricohs. Updates will be posted as they become available.
Posted Jan 22, 2026 - 15:53 EST
This incident affects: Email.