Scanning From Ricoh's Issue

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 15:30 EDT

Investigating

Scanning to email from Ricoh devices is currently unavailable. IT is actively working on a resolution
Posted Oct 14, 2025 - 15:02 EDT
This incident affected: Other Applications (Other Application).